ThinkGeo.com    |     Blog    |     Wiki    |     Support

GeoTiff displays as black rectangle or not at all

Hi,

Product: MS Desktop for Winforms version 10

We are having a problem with some specific GeoTiffs that will not display properly. If we use the ‘Managed’ GeoTiffRasterLayer the GeoTiff does not display at all. If we try the UnmanagedGeoTiffRasterLayer we simply get a black rectangle. I suspect this is a problem with these particular GeoTiffs because other GeoTiffs work fine.

Also I think the GeoTiffs that will not display properly may be in some format not supported by MapSuite. These same GeoTiffs display properly in other GIS products.

I would like to send you one of the GeoTiffs so you can have a look, but it its too large. How can I get it too you?

Thanks!

Steve

Hi Steve,

You can put your data in netdisk for example GoogleDrive, then sent us the download link.

Our developer will download it and look into this problem.

Regards,

Ethan

Thanks for responding.

Here is the link to the file.

Cheers!

Steve

Hi Steve,

Thanks for your data.

I download it yesterday and sent it to our developer, after research it our developer found it is not supported in our currently version. We tried to find a workaround for it but also failed.

In our next big version, load geotiff will get big changes, maybe it can support more special geotiff data.

Regards,

Ethan

1 Like

Hi, i´m having the same issue with geotiff but in webforms, do you have an estimate of when an update will come out?

Hi Mauricio_Tanuz_Navar,

The same behavior not means it’s the same reason, if possible could you please provide us a sample data, so we can see whether yours is the same reason just like Setven.

And our next version should coming this year, support team don’t have the detail date about it.

Regards,

Ethan

puntos_mapa_calor.zip (134.2 KB)

Here is the sample data i am using.

Hi Mauricio_Tanuz_Navar,

Your data is shape file but not geotiff file, does you upload incorrect data?

Regards,

Ethan

Indeed I sent the wrong file, sorry.

Hi Mauricio_Tanuz_Navar,

Thanks for your date, we tested it and found it’s the same reason.

It cannot be loaded by GeoTiffRasterLayer and loaded as a black area by UnmanagedGeoTiffRasterLayer.

In fact in our new ThinkGeo version 1, the tiff will get loaded under a totally new framework.

But we don’t have an estimate about the release date.

Regards,

Ethan

Thank you for your time and answer, i’ll be waiting for the new version.

Hi Mauricio_Tanuz_Navar,

Thank you for your attention, we will update the new product in our main page.

Any question please let us know.

Regards,

Ethan