ThinkGeo.com    |     Blog    |     Wiki    |     Support

Problem after updating nuget packages

As per subject line, the problem seems to be to do with System.Data.SQLite.Core. Having upgraded, my solution now uses version 1.0.110. However, the solution also has a dependency on version 1.0.102.0 (due to MapSuiteDependency-SQLiteCore version 10.5.0). I do not seem to be able to downgrade from version 1.0.110 to version 1.0.102.0 in the Package Manager. Would be grateful for any clues as to how I resolve this issue.

Please note that all projects within the solution now target .NET Framework 4.7.2, perhaps this is preventing me from downgrading?

I was able to resolve this problem by uninstalling and re-installing System.Data.SQLite.

Hi Daniel,

Does your project need to use the System.Data.SQLite.Core directly? If you only use that in our map, you don’t need to install this package, you just need our MapSuiteDependency-SQLiteCore.

If you need to use that dll, please make sure the Sqlite dll version is just the same, the different version than System.Data.SQLite.Core.1.0.102.0 cannot make it works.

I think the uninstall and reinstall is good solution for it.

Why you cannot downgrade that should because this pacakge disable older version, view its page you can see the history of it had been hidden. https://www.nuget.org/packages/System.Data.SQLite.Core/

Regards,

Ethan

Hi Ethan,

Many thanks for the information.

Regards,

Dan.

Hi Daniel,

I am glad to hear that’s helpful.

Any question please feel free to let us know.

Regards,

Ethan