|     Blog    |     Wiki    |     Support

TypeLoadException when starting the GISEditor

I have downloaded and compiled the latest GISEditor (the one referencing the version 10.5 of the ThinkGeo dlls) and am having problems running it on one machine. (Other machines don’t have this issue for some reason). I have copied the entire contents of the output directory to a folder on a server that a co-worker has copied down onto his desktop as a folder. When he attempts to start the application on his machine he gets an error. I have tracked this down to the following LoaderException: System.IO.FileNotFoundException: Could not load file or assembly ‘ESRI.FILEGDBAPI.dll’ or one of its dependencies. The specified module could not be found. File name: ‘ESRI.FILEGDBAPI.dll’

I have verified that this file does indeed exist in the the EsriFileGeoDatabase directory under both the Windows-X64 and Windows-X86 directories on his machine.

I even tried having him copy the folder directly to his C: drive an run it from there only to be met with the same issue. I have also tried having him run it directly from the server folder and he still gets the same issue.

The strange thing is that on another machine of his, it works fine. So the question is why doesn’t it work on this one machine?


Hi Travis,

Our support team had received your email.

Base on your provided information, we think your problem is caused by missing some system runtime.

When you use Visual Studio to build GisEditor, VS will restore NuGet packages and our NuGet packages will install the system runtime. So it works fine on your building machines.

But if your server machines don’t have the system runtimes, the GisEditor doesn’t work.
Please check that the below files exist in “C:\Windows\System32” and “C:\Windows\SysWOW64” on your server machines:

If not, please install MapSuite Runtime Dependencies merge module on your server machines. You can download it from

If you have any questions, please feel free to contact us.



I downloaded and installed the Merge Module in the link on the machine in question and verified that it placed those file in the directories you specified and the problem still persists. I think I should clarify that this is not a server machine: it is a laptop. And the same exact build output copied to 3 other non-development machine works…

Hi Travis,

Just like you mentioned, it works in other 3 machines, so I think that’s maybe the environment problem.

In fact I am not sure why the dll cannot be found, could you please search the “ESRI.FILEGDBAPI.dll” in your machine and see whether it’s exsit in any folder?

And could you please let us know your laptop envrionment include its brand, the framework version and OS version etc.

If we can find a test machine to reproduce that, I think it’s should be helpful.



As I mentioned in my original post, the file does exist in both sudirectories beneath the main GIS Editor directory as is standard. I literally copied the build output form my machine to a folder on a server and copied the contents of that folder down to the machine in question.

Regarding the environment of the machine, here’s some info on that:

Dell 5530 Mobile Precision Workstation
Windows 10 Pro 64 bit OS
Intel Core i7-8850H CPU @ 2.6 GHZ
NVidia Quadro P1000 Graphics Card
No Pen or touch input is enabled for the display
.NET Framework 4.7.03190 is installed
It is hooked to 2 external 4K monitors

Hi Travis,

We found Dell laptop for test(It’s not just the same model), but still hadn’t reproduced that.

We think it’s be an environment problem, we can try to solve it from the exception information “Could not load file or assembly ‘ESRI.FILEGDBAPI.dll’ or one of its dependencies”, here we have a topic about this exception before:

In this topic, we provided some workaround for user and after try the steps, their same exception get solved, could you please try that also and see whether it is helpful?