ThinkGeo.com    |     Blog    |     Wiki    |     Support

WMK in version 10

How would we implement the previous OsmWorldMapKitLayer in the new release? I can’t seem to figure out the right way to do it.

Hi Clay,

For 10.0 the OsmWorldMapKitLayer hadn’t been supported for now, if you want to use OSM as background layer, please try the WorldStreetsAndImageryOverlay class.

As below is how to start with our 10.0 http://wiki.thinkgeo.com/wiki/media/map_suite_desktop_for_wpf_hello_world

Wish that’s helpful.

Regards,

Don

Does the WorldStreetsAndImageryOverlay require purchasing a separate license?

Also, does the fact that the OsmWorldMapKitLayer is not “supported for now” mean that it will eventually be supported, or that it will be deprecated?

Thanks,

Clay

Hi Clay,

I think the WorldStreetsAndImageryOverlay just require the worldmapkit server license, which is also required by the old version. If you don’t have that, the tile image should get watermarker.

I asked with our developer again, it looks the OsmWorldMapKitLayer had been renamed, and you can find that here:

Wish that’s helpful.

Regards,

Don