|     Blog    |     Wiki    |     Support

Buffer Polygon With Square End Cap


I’ve noticed that if I try and create a buffer on a polygon with a Square buffer cap that you end up getting the same result as if I used the Round option.

Also, buffer option for a point using Butt produces a null object. I think at the least it should just return the point.

Attached is a test project. I am using version 9.0.632.0.

Can you please look into this fix? (43.8 KB)


Hi Damian,

Thanks for your sample, it shows this problem clearly.

Our developer will look into it, and I will update here if I get any news about it.



Hi Damian,

  1. For the point using Butt get a null object, please choose the other library NTS for that, the code as below shows how to use it.

MultipolygonShape pt1 = SqlTypesGeometryHelper.Buffer(pointShape, 2000, 4, BufferCapType.Butt, GeographyUnit.Meter, DistanceUnit.Meter);

  1. With the two libraries SqlTypes and NTS, the polygon with Square buffer just get the same result. I am not sure whether it’s an incorrect result, but I think before we find another professional library we cannot validate this. If you found any 3rd part library get the different result please let us know, so we can do further research based on that.

Please see attached sheet which shows the test result for the two libraries, wish that’s helpful.