ThinkGeo.com    |     Blog    |     Wiki    |     Support

Errors with the FDO libraries

I’m having trouble loading in a .mdb file again.

Create a new layer like so:

PersonalGeoDatabaseFeatureLayer personalGeoDatabaseFeatureLayer = new PersonalGeoDatabaseFeatureLayer(path, "FeatGUID", null, tableName);
personalGeoDatabaseFeatureLayer.ZoomLevelSet.ZoomLevel01.DefaultAreaStyle = AreaStyles.CreateSimpleAreaStyle(GeoColor.SimpleColors.Green);
personalGeoDatabaseFeatureLayer.ZoomLevelSet.ZoomLevel01.DefaultLineStyle = LineStyles.CreateSimpleLineStyle(GeoColor.FromArgb(100, GeoColor.SimpleColors.Green), 2, true);
personalGeoDatabaseFeatureLayer.ZoomLevelSet.ZoomLevel01.DefaultPointStyle = PointStyles.CreateSimplePointStyle(PointSymbolType.Cross, GeoColor.SimpleColors.Green, 2);
personalGeoDatabaseFeatureLayer.ZoomLevelSet.ZoomLevel01.ApplyUntilZoomLevel = ApplyUntilZoomLevel.Level20;

mdbOverlay.Layers.Add(layer.Name, layer); //this overlay is already added to the map
Map.Refresh(); //this is where the error occures

On the Map.Refresh(), I get two errors.

And

I’ve never seen these before and have no idea why it started doing it? I tried reinstalling the fdo package thinkgeo provides through nuget but I get the same error.

Below is the attached .mdb file I’m using. A table you can test out is ContactPt in the file.
<a class=“attachment"href=”/uploads/default/original/3X/4/7/47c711e6d4684007c211b3f42fdc3a43641fdd2f.zip">Portsmouth_2000.zip (790.0 KB)
.

Hi Dan,

It looks work well in my end.

And here is the sample:

9176.zip (773.9 KB)

Regards,

Ethan