|     Documentation    |     Premium Support

InMemoryLayer not zoomed by MouseEvents

today I updated my Solution from Version 13.0.0-beta 259 to 13.0.0-beta 330. After that, some of my layers are not refreshed, when I use the mousewheel or when I use a zoom rectangle. Only when I use the PanZoomBar-Tool they will be refreshed.
After some tests, it look’s that these behavior effects only InMemory-Layers. In the version 259 my app works correctly.

Before I make a solution, for demonstration - is this already known?

Hey @Torsten,

No, this is not a known issue. I tried to recreate what you are describing in a demo WPF app, but zooming with the mouse for my InMemoryFeatureLayer behaved as expected:

When you updated your solution to beta 330, was ThinkGeo.Core also updated to beta 279?

If you can provide a demo project that reproduces this issue, that will help us narrow down the cause and solve the issue.

Kyle (35.9 KB)

Sorry Kyle_Day,
I was to fast with the Replay-Button.
In my last Replay the is some code to reproduce the issue.
Regards Torsten

Hey @Torsten,

I made an application using your code, but I was still not able to recreate your issue. I’m using .NET Framework 4.8 (and tested on .NET Core) and ThinkGeo.UI.Wpf v13.0.0-330beta. See attached project and see if it still doesn’t work for you: (36.4 KB)