ThinkGeo.com    |     Blog    |     Wiki    |     Support

Map Suite 10 with .net core

What is the best way, if at all, to use Map Suite v10 from a .net core application? Does ThinkGeo support any level of .NetStandard ?

Hi MyAgDevTeam,

Our next release V11 will implement the map based on DotNetStandard 2.0.

Some APIs in our currently map should support DotNet Core, but not all support them and we don’t have a list about it, because we don’t have tested it. Follow our DotNetStandard version release, all functions in MapSuiteCore will support DotNet Core.

Regards,

Ethan

Thank you Ethan for adding some clarity around .net core. (1) Do you have a timetable for your v11 release? (2) I see there are already some beta packages available on nuget. How production ready do you regard these beta releases?

Regards,

MyAgData

Hi MyAgData,

Our development team is working for build the V11 release, but we don’t have a timeable for public now, because it related with most of our products, and our focus is GisServer now.

Our v11 beta is equal v10 development edition.

Regards,

Ethan

Hi MyAgData,

Our developer is developing the MapSuite V11, it is based on .net standard 2.0. WPF version and WinForms version will based on .net core 3.0.

Regards,

Ethan