|     Documentation    |     Premium Support

MBTiles example broken, SQL


I am download .
But the map is not displayed. Instead of card “INPUT string was not in a correct format”.

I created an empty project(.net core) and rewrote the code from the current project. But there was a new mistake “sqlite error 14 unable to open database file”

p.s. if I create net framework project mistake saved(Sql error 14).


Thanks Roman,
I tested the sample on few of our machines. It works.

I think this issue may something with the data path name. Can you try to copy the sample project to a simple English path such as D:\test. If still not work you may need change your windows environment to English one.

Go ahead let us know if this still not working. We could schedule a share screen meeting to dig into more detail.



Thank Frank4,
Changing the environment to English helped me.

How to remove the impact of the system on performance?
The program should work on systems with different languages.

Could you give us a screenshot about your system on performance? I tested with few different environments. It works very well. We must miss some environment.



Here are the parameters of my system.

systemInfo.bmp (2.0 MB)

If you test, then the preferred language of the system is Ukrainian / Russian.



Thanks Roman,
I can re-produce this issue by change the environment. We have fixed this issue. After you download the sample. You could update the thinkgeo nuget package to the latest one. Then it will work.

This sample only contain the NewYorkCity. For more data please check out