ThinkGeo.com    |     Blog    |     Wiki    |     Support

Use a UNC path with WorldMapKit?

Is it possible to use a UNC path for the sqlite file? I’m doing the following (btw, the code formatter doesn’t seem to be working): 



OsmWorldMapKitLayer osmWorldMapKitLayer = new OsmWorldMapKitLayer(“Data Source=\\server\share\WorldMapKit.sqlite;Version=3;Read Only=True;”, OsmWorldMapKitDatabaseType.Sqlite);

and I get an error in the map background which says “unable to open database file”. I did find this
     sqlite.1065341.n5.nabble.com/System-Data-SQLite-and-UNC-Paths-td72920.html
so I tried it with eight backslashes (i.e. four escaped backslashes) with the same result. If I map the share to a drive, it works just fine. However, that’s not necessarily an option for me on our production box…



Hi Jay, 



Please try following: 


OsmWorldMapKitLayer osmWorldMapKitLayer = new OsmWorldMapKitLayer("Data Source=\\\\server\share\WorldMapKit.sqlite;Version=3;Read Only=True;", OsmWorldMapKitDatabaseType.Sqlite);

Or 


OsmWorldMapKitLayer osmWorldMapKitLayer = new OsmWorldMapKitLayer(@"Data Source=\\server\share\WorldMapKit.sqlite;Version=3;Read Only=True;", OsmWorldMapKitDatabaseType.Sqlite);

Thanks, 

Peter

Hi Peter, thanks for the suggestions. I had already tried the leading eight backslashes without success. I hadn’t tried the verbatim string literal approach, but when I did, that met with no luck either. Just for fun, I tried combining the two, and that didn’t work either.

Huh, that’ll teach me. The actual path being used was being constructed based on a config setting. I plugged the correct location in directly rather than going through that logic, and both the verbatim string and the eight backslash approaches worked.



So it appears my problem is in how to specify it in the config setting, and the logic that uses it.



Thanks for the help!

Hi Jay, 
  
 Glad to hear it works. 
  
 Thanks, 
 Peter