ThinkGeo.com    |     Blog    |     Wiki    |     Support

World Map Kit Data Extractor Blank

Hello,

I have tried a few times to extract data from my world map kit SDK file. The tool generates .sqlite file without incident, but I appear to be getting a blank blue screen whenever I try to access the data. I am using the webAPI, but my controller code that generates the map data is:

OsmWorldMapKitLayer myLayer = new OsmWorldMapKitLayer(ConfigurationManager.AppSettings[“SqliteConnectionString”], OsmWorldMapKitDatabaseType.Sqlite);
myLayer.Open();

LayerOverlay overlay = new LayerOverlay();
overlay.Layers.add(myLayer);

using (Bitmap bitmap = new Bitmap(256, 256))
{
GdiPlusGeoCanvas geoCanvas = new GdiPlusGeoCanvas();
RectangleShape boundingBox = WebApiExtentHelper.GetBoundingBoxForXyz(x, y, z, GeographyUnit.Meter);
geoCanvas.BeginDrawing(bitmap, boundingBox, GeographyUnit.Meter);
layerOverlay.Draw(geoCanvas);
geoCanvas.EndDrawing();

MemoryStream ms = new MemoryStream();
bitmap.Save(ms, ImageFormat.Png);

            HttpResponseMessage msg = new HttpResponseMessage(HttpStatusCode.OK);
            msg.Content = new ByteArrayContent(ms.ToArray());
            msg.Content.Headers.ContentType = new MediaTypeHeaderValue("image/png");

            return msg;
        }

This worked fine for the world map file and the las vegas sample file, but only gives me a blue screen when using an extracted file. Worth noting is that the only data I can get appear at all is the zoom levels if I check the box "Preserve Country-Level Data for ZoomLevel to ZomeLevel " Once I pass the country zoom level, the map is blank.

Any help is appreciated, thanks.

Hi Daren,

I tried to extract data from vegas sample file, it trim succeed and render correct.

Could you please attach some screen shots to show us your settings in UI and the render status.

And please make sure your data is the latest version, the code should be the latest. If the version is not match, you will met many problem.

Regards,

Don