ThinkGeo.com    |     Blog    |     Wiki    |     Support

World Map Kit Data Extractor error

Hi,
I have not been able to get this tool to run. Here are the step I have taken, along with the errors I’ve run into. Pls advise. Thanks

  1. Download the evealuation database using Product Center (lasvegas3857.sqllite)

  2. Download the OSM World Map Kit Extractor (version: 2016-07-28) from: http://wiki.thinkgeo.com/wiki/map_suite_world_map_kit_sdk_all_samples#osm_world_map_kit_extractor

  3. Build error. Updating System.Data.SQLite.Core to current version (1.0.103) resolved the error.

  4. Build error: Missing ref OsmWorldMapKitLayer. Resovled by removing the reference then adding it back from: C:\Program Files (x86)\ThinkGeo\Map Suite 9.0\Map Suite World Map Kit SDK\Current Version\Managed Assemblies\OsmWorldMapKitLayer.dll

  5. Build succeeded, Execute Fail: Extractor.cs, Ln#457 (“requested value ‘numeric’ not found”)- - columnName = “scalerank”
    –> tried to work around by adding “scalerank” to Ln#442 (if (!(columnName.Equals(“scalerank”) || … )

  6. Execute Fail: Extractor.cs, Ln#183 (An exception of type ‘System.Data.SQLite.SQLiteException’ occurred in System.Data.SQLite.dll but was not handled in user code.
    Additional information: SQL logic error or missing database. duplicate column name: name

Thesea are my settings:

Hi Eric,

It looks somebody else met this issue last month.

I think you can try something like this,

Find GetTables function in Extractor.cs, see whether the SqliteColumnType contains Numeric item like this screen shot shows:

If it don’t contains that, please download latest development version 9.0.x.0 dlls.

My test version for MapSuiteCore is 9.0.379.0.

Wish that’s helpful.

Regards,

Don

Thanks Don, that fixed it.

Hi Eric,

I am glad to hear that works.

Regards,

Don