|     Documentation    |     Premium Support

RequestDrawing not redrawing layer

Basic problem I have is that I make a modification to a layer and attempt to refresh it using RequestDrawing and it does not get redrawn. In order for the refresh to take affect I have to pan the view or do a scale change operation.

Project setup I have is a Xamarin forms project using v12 of your libraries. Attached project file demonstrates the issue. app id for the bing layer needs to be set to something valid. Also in the test case I never implemented the android portion as that is working as expected in our application.

There are actually 3 issues here that concerns me.

  1. Initial display of the bing map if you do a pinch zoom application crashes. If you press the +/- buttons first the pinch zoom works fine, like wise if you place a feature first it also works fine.

  2. Refresh issue – The click me button places a feature in the center of the screen. The fealayer Toggle button toggles the visibility flag on the layer and does a requestDrawing call on the layer. Nothing occurs leaving the placed feature displayed – as mentioned zooming in/out will cause the feature to go away as expected.

  3. final issue is the Bing map disappears when zooming in. From initial display if you zoom in 8+ times the screen goes blank - Android will continue to zoom in even if no more tiles area available. (485.2 KB)

Hi Richard,

We are working on the ThinkGeo Xamarin Forms version based on V12 right now. We will have whole bunch of How-Do-I sample covering all the basic scenarios and it would be much easier for you to start your own Xamarin Forms project. So if you can, I recommend just wait maybe a couple weeks for this new version.

You might have seen we started to throw Xamarin Forms package to Nuget, for example: The current version is buggy though so please don’t use it. Keep an eye on it and we will have upgrades actively in the near future.

At the same time we are working on the 3 issues you raised in both iOS and Android edition. We will keep you posted here.


Just to be clear issues 2 and 3 are not a problem in android. I don’t know about issue 1 as I only stumbled across it with the test case which I generated only for iOS. That issue doesn’t actually show up in our application.

A quick update. We still have one issue need fix before the release. I will let you know once we get the new Xamarin Forms version release.



I tried the Xamarin forms example and simply added a button to one of the content pages in the layer display menu in the howdoISample-- button simply sets the isVisible to false and does a request drawing. Android it works, iOS it does not – same as this issue.

Hi Richard,

All the 3 issues have been fixed in both Android and iOS. Please get the latest package and have a try. Some of the fix only exist in the beta release built today so please make sure you get the latest one.


thank you – with the latest build all of my test cases now work.

Unfortunately I have other related problems – We are continuing to use our own implementation of Xamarin forms code with Thinkgeo.ui.iOS. We briefly tried switching to forms implementation but there was some missing functionality that we rely on. Instead we switched back to v12 from v10 and ran into another issue with the latest release.

We are now encountering a linker error with regards to SQLite. Duplicate symbols when linking with our own natively linked SQLite version. This error did not occur with v12.2.19, but did start occurring with 12.2.20 as well as the latest beta versions. Back before you had a sqlitefeatureLayer we created our own and we natively link our own SQLite library that has rtree enabled. switching to use you implementation of a SQLite layer is not an option at this time, and we directly use the rtree components elsewhere in our application unrelated to your libraries,

So were there any changes between 12.2.19 and 12.2.20 with regards to SQLite? Even knowing the name of the SQLite library you are using would be of help as I could then directly access the functions from that library instead of ours with little impact to our application.

We are trying to get an iOS version to one of our clients and we cannot keep delaying them.

Never mind found the SQLite implementation and was able to use it. So the compile issue is no longer a factor for us.

Thanks Richard,
Good to know it works. Go ahead let us know if you have any more questions.